What’s Vulnerable › Vulnerabilities
CVE-2026-27613: CGI Parameter Injection (Bypass of STRICT_CGI_PARAMS and EscapeShellParam)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-78
Description
TinyWeb is a web server (HTTP, HTTPS) written in Delphi for Win32. A vulnerability in versions prior to 2.01 allows unauthenticated remote attackers to bypass the web server's CGI parameter security controls. Depending on the server configuration and the specific CGI executable in use, the impact is either source code disclosure or remote code execution (RCE). Anyone hosting CGI scripts (particularly interpreted languages like PHP) using vulnerable versions of TinyWeb is impacted. The problem has been patched in version 2.01. If upgrading is not immediately possible, ensure `STRICT_CGI_PARAMS` is enabled (it is defined by default in `define.inc`) and/or do not use CGI executables that natively accept dangerous command-line flags (such as `php-cgi.exe`). If hosting PHP, consider placing the server behind a Web Application Firewall (WAF) that explicitly blocks URL query string parameters that begin with a hyphen (`-`) or contain encoded double quotes (`%22`).
Affected products
- maximmasiutin TinyWeb: before 2.01 — fixed in 2.01
How to fix
Upgrade to a fixed version: maximmasiutin TinyWeb 2.01. Check the vendor advisory for mitigations.
References
- https://github.com/maximmasiutin/TinyWeb/commit/d9dbda8db49da69d2160e1c527e782b73b5ffb6b
- https://github.com/maximmasiutin/TinyWeb/releases/tag/v2.01
- https://github.com/maximmasiutin/TinyWeb/security/advisories/GHSA-rfx5-fh9m-9jj9
- https://www.masiutin.net/tinyweb-cve-2026-27613.html
Get alerted when CVE-2026-27613 or the next vulnerability affects your stack