What’s Vulnerable › Vulnerabilities
CVE-2026-27651: NGINX ngx_mail_auth_http_module vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-07-15
- Weakness: CWE-476
Description
When the ngx_mail_auth_http_module module is enabled on NGINX Plus or NGINX Open Source, undisclosed requests can cause worker processes to terminate. This issue may occur when (1) CRAM-MD5 or APOP authentication is enabled, and (2) the authentication server permits retry by returning the Auth-Wait response header. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 0.5.15 through 0.9.7; from 1.0.0 before 1.28.3; from 1.29.0 before 1.29.7 — fixed in 1.28.3, 1.29.7
- F5 NGINX Plus: from r33 before r35; r32, r32-p1, r32-p2, r32-p3, r32-p4, r35 (+4) — fixed in r35
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.28.3, 1.29.7; F5 NGINX Plus r35. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000160383
- https://access.redhat.com/errata/RHSA-2026:10065
- https://access.redhat.com/errata/RHSA-2026:13634
- https://access.redhat.com/errata/RHSA-2026:13680
- https://access.redhat.com/errata/RHSA-2026:13839
- https://access.redhat.com/errata/RHSA-2026:14836
- https://access.redhat.com/errata/RHSA-2026:15942
- https://access.redhat.com/errata/RHSA-2026:15943
- https://access.redhat.com/errata/RHSA-2026:15945
- https://access.redhat.com/errata/RHSA-2026:15966
- https://access.redhat.com/errata/RHSA-2026:6906
- https://access.redhat.com/errata/RHSA-2026:6907
Get alerted when CVE-2026-27651 or the next vulnerability affects your stack