What’s Vulnerable › Vulnerabilities
CVE-2026-27702: Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud)
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-20
Description
Budibase is a low code platform for creating internal tools, workflows, and admin panels. Prior to version 3.30.4, an unsafe `eval()` vulnerability in Budibase's view filtering implementation allows any authenticated user (including free tier accounts) to execute arbitrary JavaScript code on the server. This vulnerability ONLY affects Budibase Cloud (SaaS) - self-hosted deployments use native CouchDB views and are not vulnerable. The vulnerability exists in `packages/server/src/db/inMemoryView.ts` where user-controlled view map functions are directly evaluated without sanitization. The primary impact comes from what lives inside the pod's environment: the `app-service` pod runs with secrets baked into its environment variables, including `INTERNAL_API_KEY`, `JWT_SECRET`, CouchDB admin credentials, AWS keys, and more. Using the extracted CouchDB credentials, we verified direct database access, enumerated all tenant databases, and confirmed that user records (email addresses) are readable. Version 3.30.4 contains a patch.
Affected products
- budibase: before 3.30.4 — fixed in 3.30.4
How to fix
Upgrade to a fixed version: budibase 3.30.4. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/commit/348659810cf930dda5f669e782706594c547115d
- https://github.com/Budibase/budibase/pull/18087
- https://github.com/Budibase/budibase/releases/tag/3.30.4
- https://github.com/Budibase/budibase/security/advisories/GHSA-rvhr-26g4-p2r8
Get alerted when CVE-2026-27702 or the next vulnerability affects your stack