What’s Vulnerable › Vulnerabilities
CVE-2026-27704: Dart SDK and Flutter SDK have Zip slip in Dart Pub package extraction
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-22
Description
The Dart and Flutter SDKs provide software development kits for the Dart programming language. In versions of the Dart SDK prior to 3.11.0 and the Flutter SDK prior to version 3.41.0, when the pub client (`dart pub` and `flutter pub`) extracts a package in the pub cache, a malicious package archive can have files extracted outside the destination directory in the `PUB_CACHE`. A fix has been landed in commit 26c6985c742593d081f8b58450f463a584a4203a. By normalizing the file path before writing file, the attacker can no longer traverse up via a symlink. This patch is released in Dart 3.11.0 and Flutter 3.41.0.vAll packages on pub.dev have been vetted for this vulnerability. New packages are no longer allowed to contain symlinks. The pub client itself doesn't upload symlinks, but duplicates the linked entry, and has been doing this for years. Those whose dependencies are all from pub.dev, third-party repositories trusted to not contain malicious code, or git dependencies are not affected by this vulnerability.
Affected products
- Google LLC Dart SDK: before 3.11.0 — fixed in 3.11.0
- Flutter: before 3.41.0 — fixed in 3.41.0
How to fix
Upgrade to a fixed version: Google LLC Dart SDK 3.11.0; Flutter 3.41.0. Check the vendor advisory for mitigations.
References
- https://github.com/dart-lang/pub/commit/26c6985c742593d081f8b58450f463a584a4203a
- https://github.com/dart-lang/sdk/security/advisories/GHSA-q739-79rh-vmvp
Get alerted when CVE-2026-27704 or the next vulnerability affects your stack