What’s Vulnerable › Vulnerabilities
CVE-2026-27742: Bludit <= 3.16.2 Stored XSS in Post Content
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-23 · updated 2026-07-14
- Weakness: CWE-79
Description
Bludit version 3.16.2 contains a stored cross-site scripting (XSS) vulnerability in the post content functionality. The application performs client-side sanitation of content input but does not enforce equivalent sanitation on the server side. An authenticated user can inject arbitrary JavaScript into the content field of a post, which is stored and later rendered to other users without proper output encoding. When viewed, the injected script executes in the context of the victim’s browser, allowing session hijacking, credential theft, content manipulation, or other actions within the user’s privileges.
Affected products
- Bludit: before 3.16.2 — fixed in 3.16.2
How to fix
Upgrade to a fixed version: Bludit 3.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/bludit/bludit/issues/1579
- https://www.vulncheck.com/advisories/bludit-stored-xss-in-post-content
Get alerted when CVE-2026-27742 or the next vulnerability affects your stack