What’s Vulnerable › Vulnerabilities
CVE-2026-27747: SPIP interface_traduction_objets < 2.2.2 Authenticated SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-89
Description
The SPIP interface_traduction_objets plugin versions prior to 2.2.2 contain an authenticated SQL injection vulnerability in interface_traduction_objets_pipelines.php. When handling translation requests, the plugin reads the id_parent parameter from user-supplied input and concatenates it directly into a SQL WHERE clause in a call to sql_getfetsel() without input validation or parameterization. An authenticated attacker with editor-level privileges can inject crafted SQL expressions into the id_parent parameter to manipulate the backend query. Successful exploitation can result in disclosure or modification of database contents and may lead to denial of service depending on the database configuration and privileges.
Affected products
- SPIP interface_traduction_objets: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: SPIP interface_traduction_objets 2.2.2. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-de-securite-sortie-de-SPIP-4-4-10.html
- https://chocapikk.com/posts/2026/spip-plugins-vulnerabilities/
- https://git.spip.net/spip-contrib-extensions/interface_traduction_objets/-/commit/db3417b7811774f04c3ff191ca1737fe660ef0be
- https://plugins.spip.net/interface_traduction_objets
- https://www.vulncheck.com/advisories/spip-interface-traduction-objets-authenticated-sql-injection
Get alerted when CVE-2026-27747 or the next vulnerability affects your stack