What’s Vulnerable › Vulnerabilities

CVE-2026-27769: Connected Workspaces: Malicious remote server can manipulate arbitrary user's status

Description

Mattermost versions 10.11.x <= 10.11.12 fail to validate whether users were correctly owned by the correct Connected Workspace which allows a malicious remote server connected using the Conntexted Workspaces feature to change the displayed status of local users via the Connected Workspaces API.. Mattermost Advisory ID: MMSA-2026-00603

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-27769 or the next vulnerability affects your stack