What’s Vulnerable › Vulnerabilities
CVE-2026-27798: ImageMagick: Heap Buffer Over-read in WaveletDenoise when processing small images
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-125
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, a heap buffer over-read vulnerability occurs when processing an image with small dimension using the `-wavelet-denoise` operator. Versions 7.1.2-15 and 6.9.13-40 contain a patch.
Affected products
- Dlemstra Magick.Net: before 14.10.3 — fixed in 14.10.3
- ImageMagick: before 6.9.13-40; from 7.0.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
How to fix
Upgrade to a fixed version: Dlemstra Magick.Net 14.10.3; ImageMagick 6.9.13-40, 7.1.2-15. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/0377e60b3c0d766bd7271221c95d9ee54f6a3738
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qpgx-jfcq-r59f
- https://github.com/dlemstra/Magick.NET/releases/tag/14.10.3
Get alerted when CVE-2026-27798 or the next vulnerability affects your stack