What’s Vulnerable › Vulnerabilities
CVE-2026-27801: Vaultwarden: 2FA Bypass on Protected Actions due to Faulty Rate Limit Enforcement
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-307
Description
Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.
Affected products
- dani-garcia vaultwarden: before 1.35.0 — fixed in 1.35.0
How to fix
Upgrade to a fixed version: dani-garcia vaultwarden 1.35.0. Check the vendor advisory for mitigations.
References
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-v6pg-v89r-w8wr
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-v6pg-v89r-w8wr
Get alerted when CVE-2026-27801 or the next vulnerability affects your stack