What’s Vulnerable › Vulnerabilities
CVE-2026-27804: Parse Server: Account takeover via JWT algorithm confusion in Google auth adapter
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-327
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.3 and 9.1.1-alpha.4, an unauthenticated attacker can forge a Google authentication token with `alg: "none"` to log in as any user linked to a Google account, without knowing their credentials. All deployments with Google authentication enabled are affected. The fix in versions 8.6.3 and 9.1.1-alpha.4 hardcodes the expected `RS256` algorithm instead of trusting the JWT header, and replaces the Google adapter's custom key fetcher with `jwks-rsa` which rejects unknown key IDs. As a workaround, dsable Google authentication until upgrading is possible.
Affected products
- parse-community parse-server: before 8.6.3; from 9.0.0 before 9.3.1; 9.3.1-alpha1, 9.3.1-alpha2, 9.3.1-alpha3 — fixed in 8.6.3, 9.3.1
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.3, 9.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/9b94083accb7f3e72c6b8126c195c7a03dd2dfd7
- https://github.com/parse-community/parse-server/commit/9d5942d50e55c822924c27b05aa98f1393e7a330
- https://github.com/parse-community/parse-server/releases/tag/8.6.3
- https://github.com/parse-community/parse-server/releases/tag/9.3.1-alpha.4
- https://github.com/parse-community/parse-server/security/advisories/GHSA-4q3h-vp4r-prv2
Get alerted when CVE-2026-27804 or the next vulnerability affects your stack