What’s Vulnerable › Vulnerabilities
CVE-2026-27808: Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-918
Description
Mailpit is an email testing tool and API for developers. Prior to version 1.29.2, the Link Check API (/api/v1/message/{ID}/link-check) is vulnerable to Server-Side Request Forgery (SSRF). The server performs HTTP HEAD requests to every URL found in an email without validating target hosts or filtering private/internal IP addresses. The response returns status codes and status text per link, making this a non-blind SSRF. In the default configuration (no authentication on SMTP or API), this is fully exploitable remotely with zero user interaction. This is the same class of vulnerability that was fixed in the HTML Check API (CVE-2026-23845 / GHSA-6jxm-fv7w-rw5j) and the screenshot proxy (CVE-2026-21859 / GHSA-8v65-47jx-7mfr), but the Link Check code path was not included in either fix. Version 1.29.2 fixes this vulnerability.
Affected products
- axllent mailpit: before 1.29.2 — fixed in 1.29.2
How to fix
Upgrade to a fixed version: axllent mailpit 1.29.2. Check the vendor advisory for mitigations.
References
- https://github.com/axllent/mailpit/commit/10ad4df8cc0cd9e51dea1b4410009545eef7fbf5
- https://github.com/axllent/mailpit/releases/tag/v1.29.2
- https://github.com/axllent/mailpit/security/advisories/GHSA-mpf7-p9x7-96r3
- https://github.com/axllent/mailpit/security/advisories/GHSA-mpf7-p9x7-96r3
Get alerted when CVE-2026-27808 or the next vulnerability affects your stack