What’s Vulnerable › Vulnerabilities
CVE-2026-27809: psd-tools: Compression module has unguarded zlib decompression, missing dimension validation, and hardening gaps
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-190
Description
psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past the expected row size), decode_rle() raises ValueError which propagated all the way to the user, crashing psd.composite() and psd-tools export. decompress() already had a fallback that replaces failed channels with black pixels when result is None, but it never triggered because the ValueError from decode_rle() was not caught. The fix in version 1.12.2 wraps the decode_rle() call in a try/except so the existing fallback handles the error gracefully.
Affected products
- psd-tools: before 1.12.2 — fixed in 1.12.2
How to fix
Upgrade to a fixed version: psd-tools 1.12.2. Check the vendor advisory for mitigations.
References
- https://github.com/psd-tools/psd-tools/commit/6c0a78f195b5942757886a1863793fd5946c1fb1
- https://github.com/psd-tools/psd-tools/releases/tag/v1.12.2
- https://github.com/psd-tools/psd-tools/security/advisories/GHSA-24p2-j2jr-386w
Get alerted when CVE-2026-27809 or the next vulnerability affects your stack