What’s Vulnerable › Vulnerabilities
CVE-2026-27810: calibre Vulnerable to HTTP Response Header Injection
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-113
Description
calibre is a cross-platform e-book manager for viewing, converting, editing, and cataloging e-books. Prior to version 9.4.0, an HTTP Response Header Injection vulnerability in the calibre Content Server allows any authenticated user to inject arbitrary HTTP headers into server responses via an unsanitized `content_disposition` query parameter in the `/get/` and `/data-files/get/` endpoints. All users running the calibre Content Server with authentication enabled are affected. The vulnerability is exploitable by any authenticated user and can also be triggered by tricking an authenticated victim into clicking a crafted link. Version 9.4.0 contains a fix for the issue.
Affected products
- kovidgoyal calibre: before 9.4.0 — fixed in 9.4.0
How to fix
Upgrade to a fixed version: kovidgoyal calibre 9.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27810 or the next vulnerability affects your stack