What’s Vulnerable › Vulnerabilities
CVE-2026-27811: Roxy-WI has a Command Injection via diff parameter in config comparison allows authenticated RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-77
Description
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.3, a command injection vulnerability exists in the `/config/compare/<service>/<server_ip>/show` endpoint, allowed authenticated users to execute arbitrary system commands on the app host. The vulnerability exists in `app/modules/config/config.py` on line 362, where user input is directly formatted in the template string that is eventually executed. Version 8.2.6.3 fixes the issue.
Affected products
- roxy-wi: before 8.2.6.3 — fixed in 8.2.6.3
How to fix
Upgrade to a fixed version: roxy-wi 8.2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/roxy-wi/roxy-wi/commit/a10ac7306c252014f97a7213db4a9470300fa064
- https://github.com/roxy-wi/roxy-wi/releases/tag/v8.2.6.3
- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-jvmv-cw47-jh77
Get alerted when CVE-2026-27811 or the next vulnerability affects your stack