What’s Vulnerable › Vulnerabilities
CVE-2026-27815: EVerest: ISO15118 session_setup payment options overflow can corrupt EVSE state
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-787
Description
EVerest is an EV charging software stack. Prior to versions to 2026.02.0, ISO15118_chargerImpl::handle_session_setup copies a variable-length payment_options list into a fixed-size array of length 2 without bounds checking. With schema validation disabled by default, oversized MQTT Cmd payloads can trigger out-of-bounds writes and corrupt adjacent EVSE state or crash the process. Version 2026.02.0 contains a patch.
Affected products
- everest-core: before 2026.02.0 — fixed in 2026.02.0
How to fix
Upgrade to a fixed version: everest-core 2026.02.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27815 or the next vulnerability affects your stack