What’s Vulnerable › Vulnerabilities
CVE-2026-27893: vLLM's hardcoded trust_remote_code=True in NemotronVL and KimiK25 bypasses user security opt-out
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-07-21
- Weakness: CWE-693
Description
vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.
Affected products
- vllm-project vllm: from 0.10.1 before 0.18.0 — fixed in 0.18.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/00bd08edeee5dd4d4c13277c0114a464011acf72
- https://github.com/vllm-project/vllm/pull/36192
- https://github.com/vllm-project/vllm/security/advisories/GHSA-7972-pg2x-xr59
- https://access.redhat.com/errata/RHSA-2026:10140
- https://access.redhat.com/errata/RHSA-2026:10141
- https://access.redhat.com/errata/RHSA-2026:19712
- https://access.redhat.com/errata/RHSA-2026:19724
- https://access.redhat.com/errata/RHSA-2026:19725
- https://access.redhat.com/errata/RHSA-2026:24977
- https://access.redhat.com/errata/RHSA-2026:37275
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:8746
Get alerted when CVE-2026-27893 or the next vulnerability affects your stack