What’s Vulnerable › Vulnerabilities
CVE-2026-27901: Svelte vulnerable to XSS during SSR with contenteditable `bind:innerText` and `bind:textContent`
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Svelte performance oriented web framework. Prior to version 5.53.5, the contents of `bind:innerText` and `bind:textContent` on `contenteditable` elements were not properly escaped. This could enable HTML injection and Cross-Site Scripting (XSS) if rendering untrusted data as the binding's initial value on the server. Version 5.53.5 fixes the issue.
Affected products
- sveltejs svelte: before 5.53.5; 5.53.5 — fixed in 5.53.5
How to fix
Upgrade to a fixed version: sveltejs svelte 5.53.5. Check the vendor advisory for mitigations.
References
- https://github.com/sveltejs/svelte/commit/0df5abcae223058ceb95491470372065fb87951d
- https://github.com/sveltejs/svelte/releases/tag/svelte%405.53.5
- https://github.com/sveltejs/svelte/security/advisories/GHSA-phwv-c562-gvmh
Get alerted when CVE-2026-27901 or the next vulnerability affects your stack