What’s Vulnerable › Vulnerabilities
CVE-2026-27939: Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-287
Description
Statmatic is a Laravel and Git powered content management system (CMS). Starting in version 6.0.0 and prior to version 6.4.0, Authenticated Control Panel users may under certain conditions obtain elevated privileges without completing the intended verification step. This can allow access to sensitive operations and, depending on the user’s existing permissions, may lead to privilege escalation. This has been fixed in 6.4.0.
Affected products
- Statamic: from 6.0.0 before 6.4.0 — fixed in 6.4.0
How to fix
Upgrade to a fixed version: Statamic 6.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/statamic/cms/commit/8639ef96217eaa682bc42e8a62769cb7c6a85d3a
- https://github.com/statamic/cms/security/advisories/GHSA-rw9x-pxqx-q789
Get alerted when CVE-2026-27939 or the next vulnerability affects your stack