What’s Vulnerable › Vulnerabilities
CVE-2026-27941: OpenLIT Vulnerable to Remote Code Execution and Secret Exposure via Misuse of `pull_request_target` in GitHub Actions Workflows
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenLIT is an open source platform for AI engineering. Prior to version 1.37.1, several GitHub Actions workflows in OpenLIT's GitHub repository use the `pull_request_target` event while checking out and executing untrusted code from forked pull requests. These workflows run with the security context of the base repository, including a write-privileged `GITHUB_TOKEN` and numerous sensitive secrets (API keys, database/vector store tokens, and a Google Cloud service account key). Version 1.37.1 contains a fix.
Affected products
- openlit: from 1.36.2 before 1.37.1 — fixed in 1.37.1
How to fix
Upgrade to a fixed version: openlit 1.37.1. Check the vendor advisory for mitigations.
References
- https://github.com/openlit/openlit/commit/4a62039a1659d6cbb8913172693f587b5fc2546c
- https://github.com/openlit/openlit/security/advisories/GHSA-9jgv-x8cq-296q
Get alerted when CVE-2026-27941 or the next vulnerability affects your stack