What’s Vulnerable › Vulnerabilities

CVE-2026-27947: Group-Office Vulnerable to Remote Code Execution (RCE)

Description

Group-Office is an enterprise customer relationship management and groupware tool. Versions prior to 26.0.9, 25.0.87, and 6.8.154 have an authenticated Remote Code Execution vulnerability in the TNEF attachment processing flow. The vulnerable path extracts attacker-controlled files from `winmail.dat` and then invokes `zip` with a shell wildcard (`*`). Because extracted filenames are attacker-controlled, they can be interpreted as `zip` options and lead to arbitrary command execution. Versions 26.0.9, 25.0.87, and 6.8.154 fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Intermesh Group-Office 25.0.87, 26.0.9, 6.8.154. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-27947 or the next vulnerability affects your stack