What’s Vulnerable › Vulnerabilities
CVE-2026-27963: Audiobookshelf has Stored XSS in Tooltip.vue via Audiobook Metadata
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Audiobookshelf is a self-hosted audiobook and podcast server. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.32.0 of the Audiobookshelf web application that allows arbitrary JavaScript execution through malicious library metadata. Attackers with library modification privileges can execute code in victim users' browsers, potentially leading to session hijacking and data exfiltration. Version 2.32.0 contains a patch for the issue.
Affected products
- advplyr audiobookshelf: before 2.32.0 — fixed in 2.32.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf 2.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf/commit/503f4611b221a5bde19024e657021670df204478
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-69cp-m725-wf78
Get alerted when CVE-2026-27963 or the next vulnerability affects your stack