What’s Vulnerable › Vulnerabilities
CVE-2026-27968: Packistry accepts expired access tokens
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-287
Description
Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.
Affected products
- packistry: before 0.13.0 — fixed in 0.13.0
How to fix
Upgrade to a fixed version: packistry 0.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/packistry/packistry/commit/7740b48f0f4ecbe63099fb056c8a146180f8b283
- https://github.com/packistry/packistry/pull/276
- https://github.com/packistry/packistry/security/advisories/GHSA-4r9m-jp53-vgmw
Get alerted when CVE-2026-27968 or the next vulnerability affects your stack