What’s Vulnerable › Vulnerabilities
CVE-2026-27971: Qwik affected by unauthenticated RCE via server$ Deserialization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-03 · updated 2026-06-17
- Weakness: CWE-502
Description
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Affected products
- QwikDev qwik: before 1.19.1 — fixed in 1.19.1
How to fix
Upgrade to a fixed version: QwikDev qwik 1.19.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27971 or the next vulnerability affects your stack