What’s Vulnerable › Vulnerabilities
CVE-2026-27974: Audiobooksheld VUlnerable to Stored XSS in WrappingMarquee.js via Audiobook Metadata (Mobile App Audio Player)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Audiobookshelf is a self-hosted audiobook and podcast server. A cross-site scripting (XSS) vulnerability exists in versions prior to 0.12.0-beta of the Audiobookshelf mobile application that allows arbitrary JavaScript execution through malicious library metadata. Attackers with library modification privileges (or control over a malicious podcast RSS feed) can execute code in victim users' WebViews, potentially leading to session hijacking, data exfiltration, and unauthorized access to native device APIs. audiobookshelf-app version 0.12.0-beta fixes the issue.
Affected products
- advplyr audiobookshelf-app: before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf-app 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf-app/commit/bab95530c8c3d7a4b4cec5b059da8b79ad50223e
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-8c9r-pvrj-vcf5
Get alerted when CVE-2026-27974 or the next vulnerability affects your stack