What’s Vulnerable › Vulnerabilities
CVE-2026-28207: Zen-C Vulnerable to Command Injection via Malicious Output Filename
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-78
Description
Zen C is a systems programming language that compiles to human-readable GNU C/C11. Prior to version 0.4.2, a command injection vulnerability (CWE-78) in the Zen C compiler allows local attackers to execute arbitrary shell commands by providing a specially crafted output filename via the `-o` command-line argument. The vulnerability existed in the `main` application logic (specifically in `src/main.c`), where the compiler constructed a shell command string to invoke the backend C compiler. This command string was built by concatenating various arguments, including the user-controlled output filename, and was subsequently executed using the `system()` function. Because `system()` invokes a shell to parse and execute the command, shell metacharacters within the output filename were interpreted by the shell, leading to arbitrary command execution. An attacker who can influence the command-line arguments passed to the `zc` compiler (like through a build script or a CI/CD pipeline configuration) can execute arbitrary commands with the privileges of the user running the compiler. The vulnerability has been fixed in version 0.4.2 by removing `system()` calls, implementing `ArgList`, and internal argument handling. Users are advised to update to Zen C version v0.4.2 or later.
Affected products
- zenc-lang zenc: before 0.4.2 — fixed in 0.4.2
How to fix
Upgrade to a fixed version: zenc-lang zenc 0.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/z-libs/Zen-C/security/advisories/GHSA-9rff-x96h-76h2
- https://f0nduesav0yarde.github.io/blog/vulnerabilities/cve-2026-28207/
- https://github.com/z-libs/Zen-C/security/advisories/GHSA-9rff-x96h-76h2
Get alerted when CVE-2026-28207 or the next vulnerability affects your stack