What’s Vulnerable › Vulnerabilities
CVE-2026-28215: hoppscotch Vulnerable to Unauthenticated Onboarding Config Takeover
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-284
Description
hoppscotch is an open source API development ecosystem. Prior to version 2026.2.0, an unauthenticated attacker can overwrite the entire infrastructure configuration of a self-hosted Hoppscotch instance including OAuth provider credentials and SMTP settings by sending a single HTTP POST request with no authentication. The endpoint POST /v1/onboarding/config has no authentication guard and performs no check on whether onboarding was already completed. A successful exploit allows the attacker to replace the instance's Google/GitHub/Microsoft OAuth application credentials with their own, causing all subsequent user logins via SSO to authenticate against the attacker's OAuth app. The attacker captures OAuth tokens and email addresses of every user who logs in after the exploit. Additionally, the endpoint returns a recovery token that can be used to read all stored secrets in plaintext, including SMTP passwords and any other configured credentials. Version 2026.2.0 fixes the issue.
Affected products
- hoppscotch: before 2026.2.0 — fixed in 2026.2.0
How to fix
Upgrade to a fixed version: hoppscotch 2026.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/hoppscotch/hoppscotch/releases/tag/2026.2.0
- https://github.com/hoppscotch/hoppscotch/security/advisories/GHSA-jwv8-867r-q9fg
Get alerted when CVE-2026-28215 or the next vulnerability affects your stack