What’s Vulnerable › Vulnerabilities
CVE-2026-28216: hoppscotch has IDOR in updateUserEnvironment / deleteUserEnvironment
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-639
Description
hoppscotch is an open source API development ecosystem. Prior to version 2026.2.0, any logged-in user can read, modify or delete another user's personal environment by ID. `user-environments.resolver.ts:82-109`, `updateUserEnvironment` mutation uses `@UseGuards(GqlAuthGuard)` but is missing the `@GqlUser()` decorator entirely. The user's identity is never extracted, so the service receives only the environment ID and performs a `prisma.userEnvironment.update({ where: { id } })` without any ownership filter. `deleteUserEnvironment` does extract the user but the service only uses the UID to check if the target is a global environment. Actual delete query uses WHERE { id } without AND userUid. hoppscotch environments store API keys, auth tokens and secrets used in API requests. An authenticated attacker who obtains another user's environment ID can read their secrets, replace them with malicious values or delete them entirely. The environment ID format is CUID, which limits mass exploitation but insider threat and combined info leak scenarios are realistic. Version 2026.2.0 fixes the issue.
Affected products
- hoppscotch: before 2026.2.0 — fixed in 2026.2.0
How to fix
Upgrade to a fixed version: hoppscotch 2026.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/hoppscotch/hoppscotch/releases/tag/2026.2.0
- https://github.com/hoppscotch/hoppscotch/security/advisories/GHSA-72rv-vc3j-5vqr
Get alerted when CVE-2026-28216 or the next vulnerability affects your stack