What’s Vulnerable › Vulnerabilities
CVE-2026-28218: Discourse's Fail-Open Access Control in Data Explorer Plugin Allows Unauthorized SQL Query Execution
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-284
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, fail-open access control in Data Explorer plugin allows any authenticated user to execute SQL queries that have no explicit group assignments, including built-in system queries. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. As a workaround, either explicitly set group permissions on each Data Explorer query that doesn't have permissions, or disable discourse-data-explorer plugin.
Affected products
- discourse: before 2025.12.2; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.2, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.2, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-28218 or the next vulnerability affects your stack