What’s Vulnerable › Vulnerabilities
CVE-2026-28220: Wazuh cluster DAPI arbitrary callable deserialization and RBAC context injection allow a cluster peer to execute privileged functions on the master node
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-20 · updated 2026-07-29
- Weakness: CWE-502
Description
Wazuh is a free and open source platform used for threat prevention, detection, and response. Prior to version 4.14.5, issues in the Cluster Distributed API (DAPI) handling allow a cluster peer, or any actor able to authenticate to the cluster channel using the shared cluster key, to make the master node deserialize an attacker-controlled callable and execute it under an attacker-controlled RBAC context. The cluster code in `framework/wazuh/core/cluster/common.py` deserializes JSON with `as_wazuh_object()`, which resolves any callable whose top-level package is wazuh or api (an overly broad allowlist controlled only by `ALLOWED_CALLABLES_PACKAGES`), and DAPI requests handled in framework/wazuh/core/cluster/dapi/dapi.py accept a client-supplied rbac_permissions value that `run_local()` applies as the global RBAC context, so supplying an rbac_mode of black causes authorization checks for expose_resources-protected functions to pass without any legitimate permission assignment. Combined, these allow privileged administrative actions on the master node such as arbitrary file writes under WAZUH_PATH, creation of new API users, and tampering with security.yaml, and can be chained into full manager compromise. This issue has been fixed in version 4.14.5.
Affected products
- wazuh: from 4.0.0 before 4.14.5 — fixed in 4.14.5
How to fix
Upgrade to a fixed version: wazuh 4.14.5. Check the vendor advisory for mitigations.
References
- https://github.com/wazuh/wazuh/security/advisories/GHSA-w2jj-pfq9-mh9p
- https://github.com/wazuh/wazuh/security/advisories/GHSA-w2jj-pfq9-mh9p
Get alerted when CVE-2026-28220 or the next vulnerability affects your stack