What’s Vulnerable › Vulnerabilities
CVE-2026-28222: Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on rendering TableBlock blocks within a StreamField. A user with access to create or edit pages containing TableBlock StreamField blocks is able to set specially-crafted class attributes on the block which run arbitrary JavaScript code when the page is viewed. When viewed by a user with higher privileges, this could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites using TableBlock. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
Affected products
- wagtail: before 6.3.8; from 6.4 before 7.0.6; from 7.1 before 7.2.3; 7.3, 7.3-rc1 — fixed in 6.3.8, 7.0.6, 7.2.3
How to fix
Upgrade to a fixed version: wagtail 6.3.8, 7.0.6, 7.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/wagtail/wagtail/commit/0375094bb57ce6e527005c2bb2e871dd20bca04d
- https://github.com/wagtail/wagtail/commit/4620423cb22c5253391a0f04178089c1162f6e2e
- https://github.com/wagtail/wagtail/commit/575c0d7c18c7716ed73f7a3c2720ad75956f0a85
- https://github.com/wagtail/wagtail/commit/605a5569686565e035313222e1bc2f9802fbc55b
- https://github.com/wagtail/wagtail/releases/tag/v6.3.8
- https://github.com/wagtail/wagtail/releases/tag/v7.0.6
- https://github.com/wagtail/wagtail/releases/tag/v7.2.3
- https://github.com/wagtail/wagtail/releases/tag/v7.3.1
- https://github.com/wagtail/wagtail/security/advisories/GHSA-p5cm-246w-84jm
Get alerted when CVE-2026-28222 or the next vulnerability affects your stack