What’s Vulnerable › Vulnerabilities
CVE-2026-28223: Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
Affected products
- wagtail: before 6.3.8; from 6.4 before 7.0.6; from 7.1 before 7.2.3; 7.3, 7.3-rc1 — fixed in 6.3.8, 7.0.6, 7.2.3
How to fix
Upgrade to a fixed version: wagtail 6.3.8, 7.0.6, 7.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/wagtail/wagtail/commit/1c6f2effed68f4ccad6fbd07987e03641505f863
- https://github.com/wagtail/wagtail/commit/ba70244d376a7b1bd180ded03e827917ff410c19
- https://github.com/wagtail/wagtail/commit/d8c5900982df8ed5938ad993aa9ff69cda50f80c
- https://github.com/wagtail/wagtail/commit/ee39d39deeb7f250fe886417b24802d7e05b1143
- https://github.com/wagtail/wagtail/releases/tag/v6.3.8
- https://github.com/wagtail/wagtail/releases/tag/v7.0.6
- https://github.com/wagtail/wagtail/releases/tag/v7.2.3
- https://github.com/wagtail/wagtail/releases/tag/v7.3.1
- https://github.com/wagtail/wagtail/security/advisories/GHSA-p4v8-rw59-93cq
Get alerted when CVE-2026-28223 or the next vulnerability affects your stack