What’s Vulnerable › Vulnerabilities
CVE-2026-28272: Kiteworks Email Protection Gateway has a Cross-site Scripting vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Kiteworks is a private data network (PDN). Prior to version 9.2.0, a vulnerability in Kiteworks Email Protection Gateway allows authenticated administrators to inject malicious scripts through a configuration interface. The stored script executes when users interact with the affected user interface. Version 9.2.0 contains a patch for the issue.
Affected products
- Kiteworks Email Protection Gateway: before 9.2.0 — fixed in 9.2.0
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-28272 or the next vulnerability affects your stack