What’s Vulnerable › Vulnerabilities
CVE-2026-28282: Discourse vulnerable to group membership addition permission bypass via discourse-policy plugin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-863
Description
Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 have a security flaw in the discourse-policy plugin which allowed a user with policy creation permission to gain membership access to any private/restricted groups. Once membership to a private/restricted group has been obtained, the user will be able to read private topics that only the group has access to. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, review all policies for the use of `add-users-to-group` and temporarily remove the attribute from the policy. Alternatively, disable the discourse-policy plugin by disabling the `policy_enabled` site setting.
Affected products
- discourse: from 2026.1.0 before 2026.1.2; from 2026.2.0 before 2026.2.1; 2026.3.0 — fixed in 2026.1.2, 2026.2.1
How to fix
Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/64e2514ac17046cfaa8bc68a3c5140bc40736add
- https://github.com/discourse/discourse/commit/c14b8a4cc5fc94e4839a83c5d55765897589f45b
- https://github.com/discourse/discourse/commit/dcde9de530f515e88f99957056ffbcc2e1e03951
- https://github.com/discourse/discourse/security/advisories/GHSA-6cc8-x3rm-j5pf
Get alerted when CVE-2026-28282 or the next vulnerability affects your stack