What’s Vulnerable › Vulnerabilities

CVE-2026-28292: simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE

Description

`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.

Affected products

How to fix

Upgrade to a fixed version: simple-git 3.32.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-28292 or the next vulnerability affects your stack