What’s Vulnerable › Vulnerabilities

CVE-2026-28370

Description

In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in _create_query_function in vitrage/graph/query.py.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Vitrage 12.01, 13.0.1, 14.0.1, 15.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-28370 or the next vulnerability affects your stack