What’s Vulnerable › Vulnerabilities
CVE-2026-28384: Authenticated RCE via unsanitized compression_algorithm
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-12 · updated 2026-09-18
- Weakness: CWE-78
Description
An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.
Affected products
- Canonical LXD: from 4.12 before 5.0.6; from 5.21.0 before 5.21.4; from 6.0 before 6.7 — fixed in 5.0.6, 5.21.4, 6.7
How to fix
Upgrade to a fixed version: Canonical LXD 5.0.6, 5.21.4, 6.7. Check the vendor advisory for mitigations.
References
- https://discourse.ubuntu.com/t/lxd-authenticated-remote-code-execution-fixes-available/78365
- https://github.com/canonical/lxd/commit/043696a13171ace7dd4c2b32d34ce039ab629052
- https://github.com/canonical/lxd/commit/7046979645c2ce1b63b2f9e60ddf6cbc4c4b78f9
- https://github.com/canonical/lxd/commit/b7b411caf5c4971bfe2386c72128f44d7e2aaf4f
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g
Get alerted when CVE-2026-28384 or the next vulnerability affects your stack