What’s Vulnerable › Vulnerabilities
CVE-2026-28392: OpenClaw < 2026.2.14 - Privilege Escalation in Slack Slash Command Handler via Direct Messages
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw versions prior to 2026.2.14 contain a privilege escalation vulnerability in the Slack slash-command handler that incorrectly authorizes any direct message sender when dmPolicy is set to open (must be configured). Attackers can execute privileged slash commands via direct message to bypass allowlist and access-group restrictions.
Affected products
- OpenClaw: before 2026.2.14 — fixed in 2026.2.14
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.14. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/f19eabee54c49e9a2e264b4965edf28a2f92e657
- https://github.com/openclaw/openclaw/security/advisories/GHSA-v773-r54f-q32w
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-in-slack-slash-command-handler-via-direct-messages
Get alerted when CVE-2026-28392 or the next vulnerability affects your stack