What’s Vulnerable › Vulnerabilities
CVE-2026-28412: Textream Vulnerable to Uncontrolled Resource Consumption (Denial of Service)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-02 · updated 2026-06-17
- Weakness: CWE-400
Description
Textream is a free macOS teleprompter app. Prior to version 1.5.1, the `DirectorServer` WebSocket server imposes no limit on concurrent connections. Combined with a broadcast timer that sends state to all connected clients every 100 ms, an attacker can exhaust CPU and memory by flooding the server with connections, causing the Textream application to freeze and crash during a live session. Version 1.5.1 fixes the issue.
Affected products
- f textream: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: f textream 1.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/f/textream/commit/3524fa96f98ba17025b48ce9e19d49d859fc2ec1
- https://github.com/f/textream/security/advisories/GHSA-qr5p-7x47-qxh9
Get alerted when CVE-2026-28412 or the next vulnerability affects your stack