What’s Vulnerable › Vulnerabilities
CVE-2026-28417: Vim has OS Command Injection in netrw
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-86
Description
Vim is an open source, command line text editor. Prior to version 9.2.0073, an OS command injection vulnerability exists in the `netrw` standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the `scp://` protocol handler), an attacker can execute arbitrary shell commands with the privileges of the Vim process. Version 9.2.0073 fixes the issue.
Affected products
- vim/vim: before 9.2.0073 — fixed in 9.2.0073
How to fix
Upgrade to a fixed version: vim/vim 9.2.0073. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/79348dbbc09332130f4c860
- https://github.com/vim/vim/releases/tag/v9.2.0073
- https://github.com/vim/vim/security/advisories/GHSA-m3xh-9434-g336
- http://www.openwall.com/lists/oss-security/2026/02/27/6
Get alerted when CVE-2026-28417 or the next vulnerability affects your stack