What’s Vulnerable › Vulnerabilities
CVE-2026-28421: Vim has a heap-buffer-overflow and a segmentation fault
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-20
Description
Vim is an open source, command line text editor. Versions prior to 9.2.0077 have a heap-buffer-overflow and a segmentation fault (SEGV) exist in Vim's swap file recovery logic. Both are caused by unvalidated fields read from crafted pointer blocks within a swap file. Version 9.2.0077 fixes the issue.
Affected products
- vim/vim: before 9.2.0077 — fixed in 9.2.0077
How to fix
Upgrade to a fixed version: vim/vim 9.2.0077. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/65c1a143c331c886dc28
- https://github.com/vim/vim/releases/tag/v9.2.0077
- https://github.com/vim/vim/security/advisories/GHSA-r2gw-2x48-jj5p
- http://www.openwall.com/lists/oss-security/2026/02/27/10
Get alerted when CVE-2026-28421 or the next vulnerability affects your stack