What’s Vulnerable › Vulnerabilities
CVE-2026-28422: Vim has stack-buffer-overflow in build_stl_str_hl()
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-121
Description
Vim is an open source, command line text editor. Prior to version 9.2.0078, a stack-buffer-overflow occurs in `build_stl_str_hl()` when rendering a statusline with a multi-byte fill character on a very wide terminal. Version 9.2.0078 patches the issue.
Affected products
- vim/vim: before 9.2.0078 — fixed in 9.2.0078
How to fix
Upgrade to a fixed version: vim/vim 9.2.0078. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/4e5b9e31cb7484ad156f
- https://github.com/vim/vim/releases/tag/v9.2.0078
- https://github.com/vim/vim/security/advisories/GHSA-gmqx-prf2-8mwf
- http://www.openwall.com/lists/oss-security/2026/02/27/11
Get alerted when CVE-2026-28422 or the next vulnerability affects your stack