What’s Vulnerable › Vulnerabilities
CVE-2026-28423: Statamic Vulnerable to Server-Side Request Forgery via Glide
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-918
Description
Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.11 and 6.4.0, when Glide image manipulation is used in insecure mode (which is not the default), the image proxy can be abused by an unauthenticated user to make the server send HTTP requests to arbitrary URLs—either via the URL directly or via the watermark feature. That can allow access to internal services, cloud metadata endpoints, and other hosts reachable from the server. This has been fixed in 5.73.11 and 6.4.0.
Affected products
- Statamic: before 5.73.11; from 6.0.0 before 6.4.0 — fixed in 5.73.11, 6.4.0
How to fix
Upgrade to a fixed version: Statamic 5.73.11, 6.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/statamic/cms/releases/tag/v5.73.11
- https://github.com/statamic/cms/releases/tag/v6.4.0
- https://github.com/statamic/cms/security/advisories/GHSA-cwpp-325q-2cvp
Get alerted when CVE-2026-28423 or the next vulnerability affects your stack