What’s Vulnerable › Vulnerabilities
CVE-2026-28447: OpenClaw 2026.1.29-beta.1 < 2026.2.1 - Path Traversal in Plugin Installation via Package Name
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-22
Description
OpenClaw versions 2026.1.29-beta.1 prior to 2026.2.1 contain a path traversal vulnerability in plugin installation that allows malicious plugin package names to escape the extensions directory. Attackers can craft scoped package names containing path traversal sequences like .. to write files outside the intended installation directory when victims run the plugins install command.
Affected products
- OpenClaw: from 2026.1.29 before 2026.2.1 — fixed in 2026.2.1
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d03eca8450dc493b198a88b105fd180895238e57
- https://github.com/openclaw/openclaw/security/advisories/GHSA-qrq5-wjgg-rvqw
- https://www.vulncheck.com/advisories/openclaw-beta-path-traversal-in-plugin-installation-via-package-name
Get alerted when CVE-2026-28447 or the next vulnerability affects your stack