What’s Vulnerable › Vulnerabilities
CVE-2026-28469: OpenClaw < 2026.2.14 - Cross-Account Policy Context Misrouting via Shared Webhook Path Ambiguity
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-639
Description
OpenClaw versions prior to 2026.2.14 contain a webhook routing vulnerability in the Google Chat monitor component that allows cross-account policy context misrouting when multiple webhook targets share the same HTTP path. Attackers can exploit first-match request verification semantics to process inbound webhook events under incorrect account contexts, bypassing intended allowlists and session policies.
Affected products
- OpenClaw: before 2026.2.14 — fixed in 2026.2.14
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.14. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/61d59a802869177d9cef52204767cd83357ab79e
- https://github.com/openclaw/openclaw/security/advisories/GHSA-rq6g-px6m-c248
- https://www.vulncheck.com/advisories/openclaw-cross-account-policy-context-misrouting-via-shared-webhook-path-ambiguity
Get alerted when CVE-2026-28469 or the next vulnerability affects your stack