What’s Vulnerable › Vulnerabilities
CVE-2026-28470: OpenClaw < 2026.2.2 - Exec Allowlist Bypass via Command Substitution in Double Quotes
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-78
Description
OpenClaw versions prior to 2026.2.2 contain an exec approvals (must be enabled) allowlist bypass vulnerability that allows attackers to execute arbitrary commands by injecting command substitution syntax. Attackers can bypass the allowlist protection by embedding unescaped $() or backticks inside double-quoted strings to execute unauthorized commands.
Affected products
- OpenClaw: before 2026.2.2 — fixed in 2026.2.2
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d1ecb46076145deb188abcba8f0699709ea17198
- https://github.com/openclaw/openclaw/security/advisories/GHSA-3hcm-ggvf-rch5
- https://www.vulncheck.com/advisories/openclaw-exec-allowlist-bypass-via-command-substitution-in-double-quotes
Get alerted when CVE-2026-28470 or the next vulnerability affects your stack