What’s Vulnerable › Vulnerabilities
CVE-2026-28490: Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-203
Description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a cryptographic padding oracle vulnerability was identified in the Authlib Python library concerning the implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. Authlib registers RSA1_5 in its default algorithm registry without requiring explicit opt-in, and actively destroys the constant-time Bleichenbacher mitigation that the underlying cryptography library implements correctly. This issue has been patched in version 1.6.9.
Affected products
- authlib: before 1.6.9 — fixed in 1.6.9
How to fix
Upgrade to a fixed version: authlib 1.6.9. Check the vendor advisory for mitigations.
References
- https://github.com/authlib/authlib/commit/48b345f29f6c459f11c6a40162b6c0b742ef2e22
- https://github.com/authlib/authlib/releases/tag/v1.6.9
- https://github.com/authlib/authlib/security/advisories/GHSA-7432-952r-cw78
Get alerted when CVE-2026-28490 or the next vulnerability affects your stack