What’s Vulnerable › Vulnerabilities
CVE-2026-28493: ImageMagick has a Integer Overflow leading to out of bounds write in SIXEL decoder
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16, an integer overflow vulnerability exists in the SIXEL decoer. The vulnerability allows an attacker to perform an out of bounds via a specially crafted image. This vulnerability is fixed in 7.1.2-16.
Affected products
- ImageMagick: before 7.1.2-16 — fixed in 7.1.2-16
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-28493 or the next vulnerability affects your stack