What’s Vulnerable › Vulnerabilities
CVE-2026-28509: LangBot has a Cross Site Scripting(XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
LangBot is a global IM bot platform designed for LLMs. Prior to version 4.8.7, LangBot’s web UI renders user-supplied raw HTML using rehypeRaw, which can lead to a cross-site scripting (XSS) vulnerability. This issue has been patched in version 4.8.7.
Affected products
- langbot-app LangBot: before 4.8.7 — fixed in 4.8.7
How to fix
Upgrade to a fixed version: langbot-app LangBot 4.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/langbot-app/LangBot/commit/614621ab7b84fe50da3c6137705cde5a99429866
- https://github.com/langbot-app/LangBot/security/advisories/GHSA-w8gq-g4pc-xh3h
Get alerted when CVE-2026-28509 or the next vulnerability affects your stack