What’s Vulnerable › Vulnerabilities
CVE-2026-28514: Rocket.Chat: Users can login with any password via the EE ddp-streamer-service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-287
Description
Rocket.Chat is an open-source, secure, fully customizable communications platform. Prior to versions 7.8.6, 7.9.8, 7.10.7, 7.11.4, 7.12.4, 7.13.3, and 8.0.0, a critical authentication bypass vulnerability exists in Rocket.Chat's account service used in the ddp-streamer micro service that allows an attacker to log in to the service as any user with a password set, using any arbitrary password. The vulnerability stems from a missing await keyword when calling an asynchronous password validation function, causing a Promise object (which is always truthy) to be evaluated instead of the actual boolean validation result. This may lead to account takeover of any user whose username is known or guessable. This issue has been patched in versions 7.8.6, 7.9.8, 7.10.7, 7.11.4, 7.12.4, 7.13.3, and 8.0.0.
Affected products
- Rocket.Chat: before 7.8.6; from 7.9.0 before 7.9.8; from 7.10.0 before 7.10.7; from 7.11.0 before 7.11.4; from 7.12.0 before 7.12.4; from 7.13.0 before 7.13.3 — fixed in 7.10.7, 7.11.4, 7.12.4, 7.13.3, 7.8.6, 7.9.8
How to fix
Upgrade to a fixed version: Rocket.Chat 7.10.7, 7.11.4, 7.12.4, 7.13.3. Check the vendor advisory for mitigations.
References
- https://github.com/RocketChat/Rocket.Chat/commit/7d89aae0b1bd08e82b02ceab4c180b430e2c6f07
- https://github.com/RocketChat/Rocket.Chat/pull/37143
- https://github.com/RocketChat/Rocket.Chat/security/advisories/GHSA-w6vw-mrgv-69vf
Get alerted when CVE-2026-28514 or the next vulnerability affects your stack