What’s Vulnerable › Vulnerabilities
CVE-2026-28557: wpForo Forum < 2.4.16 Privilege Escalation via Role Synchronization Handler
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-28 · updated 2026-06-17
- Weakness: CWE-862
Description
wpForo Forum 2.4.14 contains a missing capability check vulnerability that allows authenticated users to trigger bulk wpForo usergroup reassignment via the wpforo_synch_roles AJAX handler. Attackers access the usergroups admin page, accessible to any authenticated user, to obtain a nonce, then remap all wpForo usergroups to arbitrary WordPress roles.
Affected products
- tomdever wpForo Forum: from 2.4.0 before 2.4.16 — fixed in 2.4.16
How to fix
Upgrade to a fixed version: tomdever wpForo Forum 2.4.16. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpforo/
- https://wordpress.org/plugins/wpforo/#developers
- https://www.vulncheck.com/advisories/wpforo-forum-privilege-escalation-via-role-synchronization-handler
Get alerted when CVE-2026-28557 or the next vulnerability affects your stack